Вы здесь

Друпал 8 перестанет поддерживать PHP 5.5 и 5.6 с 6 марта 2019 года

В версию Друпал 8.7.0 внесено изменение, которое устанавливает минимальной версией PHP для Друпала версию 7.0. Пользователям Друпала 8, сайты которых работают на PHP 5.5 и 5.6, нужно планировать обновление своей версии PHP до 7.0 или более поздней. Друпал 8.6 будет последней версией Друпала, которая поддерживает PHP 5. Друпал 8.7.0, который выйдет 6 марта 2019 года, закроет период поддержки предыдущих версий PHP.

Дополнительную информацию можно найти в группе groups.drupal.org/core.

Развитие PHP 5.5 уже прекращено разработчиками в 2016 году. PHP 5.6 также прекратил получать поддержку разработчиков PHP с января 2017 года (например, для него больше не выходят пакеты исправлений, даже если это очень серьёзные ошибки, которые влияют в том числе и на разработку Друпала) и его EOL будет в декабре 2018 года.

Автоматическое тестирование кода для Друпала 8 требует использование библиотеки PHPUnit, которая в феврале 2018 года отказалась от поддержки PHP 5.6. Некоторые другие зависимости тоже прекратили поддержку PHP 5.6 в своих последних версиях.