Вы здесь

На PHP 5.5 поддерживаются только существующие сайты, установка нового Drupal 8 требует PHP 7.0.8+

В версию Друпал 8.7.0-beta1 внесено изменение, которое позволяет установить новый сайт только в том случае, если на хостинге установлена версия PHP 7.0.8+. Поддержка PHP версии 5.5 была прекращена 21 июля 2016 года, а версии 5.6 в декабре 2018. В январе 2018 года было объявлено, что Друпал перестанет поддерживать PHP 5.5 и 5.6 с 6 марта 2019.

Новая установка сайта на хостинг с версией PHP ниже 7.0.8 приведёт к показу ошибки:

PHP 5.5 поддерживают только существующие сайты, установка нового Drupal 8 требует PHP 7.0.8+

Обновление существующего сайта на хостинге с версией PHP 5.5.9 приведёт к показу предупреждения:

PHP 5.5 поддерживают только существующие сайты, установка нового Drupal 8 требует PHP 7.0.8+

Обновите версию PHP до версии 7.0.8 или выше к декабрю 2019 года (выходу Друпала 8.8.0), иначе после этого срока вы не сможете обновлять сайты на Друпале на тех хостингах, где установлен PHP ниже версии 7.0.8.